[PATCH] D16723: [AMDGPU] Disassembler: Added basic disassembler for AMDGPU target.
Matt Arsenault via llvm-commits
llvm-commits at lists.llvm.org
Mon Feb 1 17:40:25 PST 2016
arsenm added inline comments.
Comment at: lib/Target/AMDGPU/AMDGPU.td:306
@@ -305,2 +305,3 @@
let guessInstructionProperties = 1;
+ let decodePositionallyEncodedOperands = 1;
let noNamedPositionallyEncodedOperands = 1;
> We should fix these name mismatches rather than enabling this bit. It is much safer to use the name based matching.
I think we should change the names to vdst. The way it is now I think follows the names of the operands as they appear in the ISA documentation, but the document isn't perfectly consistent. This is because a few instructions have a second sdst
More information about the llvm-commits