[PATCH] Rename getMaximumUnrollFactor().
spatel at rotateright.com
Tue Aug 26 10:35:52 PDT 2014
Thanks very much for the feedback, Hal and Renato.
I wasn't aware of the pragmas in clang - good to know about those.
In this version of the patch, I have changed the name to "getMaxVectorInterleaveFactor". I also made a bunch of interior changes in LoopVectorizer...but there are 2 "seams" where we still use "unroll":
1. I stopped short of changing the cl::opt names - if we really want to unify on "interleave" I assume we want to change those too so they match the pragmas? That will require changing 80+ test cases in test-suite. If everyone agrees that is better, I'll certainly make that change too.
2. Eventually the interleave factor becomes an ingredient in "UF", the unroll factor:
if (UF > MaxInterleaveSize)
UF = MaxInterleaveSize;
I have not looked at the logic in LV close enough to know if "UF" is the appropriate name. Any opinions?
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 12653 bytes
Desc: not available
More information about the llvm-commits