[PATCH] Rename getMaximumUnrollFactor().
aschwaighofer at apple.com
Tue Aug 26 12:00:38 PDT 2014
I also thing it makes sense to rename this to interleave factor to point out the difference between interleaved unrolling vs concatenating unrolling. Interleaving is not necessarily tied to vectorization. The fact that we interleave in the vectorizer is just an artifact of our implementation. I think it should be getMaxInterleaveFactor(). We are not necessarily interleaving vector instructions.
Thanks for cleaning this up!
More information about the llvm-commits