[PATCH] Rename getMaximumUnrollFactor().
spatel at rotateright.com
Tue Aug 26 08:28:24 PDT 2014
Hi aschwaighofer, hfinkel, nadav,
"getMaximumUnrollFactor()" isn't used by the loop unroller at all. It's strictly a loop vectorizer variable, so I propose renaming it to "getMaxVectorUnrollFactor()" with this patch. No functional change intended.
Ideally, I think we would move this subtarget-specific variable into the SchedMachineModel. That's where we already have a variable for "LoopMicroOpBufferSize" which is used by the loop unroller. If that's a good change, let me know, and I'll work on a patch for it.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 6625 bytes
Desc: not available
More information about the llvm-commits