RFC: Enable vectorization of call instructions in the loop vectorizer
renato.golin at linaro.org
Thu Dec 19 05:46:04 PST 2013
On 19 December 2013 13:38, James Molloy <James.Molloy at arm.com> wrote:
> Very reasonable, although I think the new name “getFunction” is
> ambiguous. I’d like to keep it as “getVectorizedFunction”, but with a large
> note in the doxygen that if VF == 1, it scalarizes. Same for
I agree it's ambiguous, but calling getVectorizedFunction to get a scalar
function is worse, I think... :/
Though I can't think of a better name... If anyone else has a good idea...
I know it's a bit irrelevant, so I'm not strongly bound to it. If others
think this is ok, I'm ok with it, too.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits