RFC: Enable vectorization of call instructions in the loop vectorizer
James.Molloy at arm.com
Thu Dec 19 05:47:15 PST 2013
"getTransformedFunction()"? That way it's obvious that it's doing *something*, but not tied to vectorization or scalarization and suggests the user looks at the doxygen...
From: Renato Golin [mailto:renato.golin at linaro.org]
Sent: 19 December 2013 13:46
To: James Molloy
Cc: Hal Finkel; Arnold Schwaighofer; llvm-commits
Subject: Re: RFC: Enable vectorization of call instructions in the loop vectorizer
On 19 December 2013 13:38, James Molloy <James.Molloy at arm.com<mailto:James.Molloy at arm.com>> wrote:
Very reasonable, although I think the new name "getFunction" is ambiguous. I'd like to keep it as "getVectorizedFunction", but with a large note in the doxygen that if VF == 1, it scalarizes. Same for getVectorizedCall().
I agree it's ambiguous, but calling getVectorizedFunction to get a scalar function is worse, I think... :/
Though I can't think of a better name... If anyone else has a good idea...
I know it's a bit irrelevant, so I'm not strongly bound to it. If others think this is ok, I'm ok with it, too.
-- IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.
ARM Limited, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2557590
ARM Holdings plc, Registered office 110 Fulbourn Road, Cambridge CB1 9NJ, Registered in England & Wales, Company No: 2548782
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the llvm-commits