[llvm-bugs] [Bug 43177] New: [SelectionDAG] Rename/refactor isBuildVectorAllZeros isBuildVectorAllOnes to make undef handling more obvious

via llvm-bugs llvm-bugs at lists.llvm.org
Fri Aug 30 03:48:29 PDT 2019


https://bugs.llvm.org/show_bug.cgi?id=43177

            Bug ID: 43177
           Summary: [SelectionDAG] Rename/refactor isBuildVectorAllZeros
                    isBuildVectorAllOnes to make undef handling more
                    obvious
           Product: libraries
           Version: trunk
          Hardware: PC
                OS: Windows NT
            Status: NEW
          Severity: enhancement
          Priority: P
         Component: Common Code Generator Code
          Assignee: unassignedbugs at nondot.org
          Reporter: llvm-dev at redking.me.uk
                CC: craig.topper at gmail.com, lebedev.ri at gmail.com,
                    llvm-bugs at lists.llvm.org, spatel+llvm at rotateright.com

We keep hitting issues with people not realising that these predicates can
contain some (but not all) elements that are undef. e.g. [Bug #43159]

These keep getting used in patterns like:

// fold (mul x, 0) -> 0
if (ISD::isBuildVectorAllZeros(N0.getNode())
  return N0;

Should we rename these to isBuildVectorAllZerosOrUndefs or similar? Or is there
something else we can do to help avoid this?

-- 
You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-bugs/attachments/20190830/1d70becc/attachment-0001.html>


More information about the llvm-bugs mailing list