<html>
<head>
<base href="https://bugs.llvm.org/">
</head>
<body><table border="1" cellspacing="0" cellpadding="8">
<tr>
<th>Bug ID</th>
<td><a class="bz_bug_link
bz_status_NEW "
title="NEW - [SelectionDAG] Rename/refactor isBuildVectorAllZeros isBuildVectorAllOnes to make undef handling more obvious"
href="https://bugs.llvm.org/show_bug.cgi?id=43177">43177</a>
</td>
</tr>
<tr>
<th>Summary</th>
<td>[SelectionDAG] Rename/refactor isBuildVectorAllZeros isBuildVectorAllOnes to make undef handling more obvious
</td>
</tr>
<tr>
<th>Product</th>
<td>libraries
</td>
</tr>
<tr>
<th>Version</th>
<td>trunk
</td>
</tr>
<tr>
<th>Hardware</th>
<td>PC
</td>
</tr>
<tr>
<th>OS</th>
<td>Windows NT
</td>
</tr>
<tr>
<th>Status</th>
<td>NEW
</td>
</tr>
<tr>
<th>Severity</th>
<td>enhancement
</td>
</tr>
<tr>
<th>Priority</th>
<td>P
</td>
</tr>
<tr>
<th>Component</th>
<td>Common Code Generator Code
</td>
</tr>
<tr>
<th>Assignee</th>
<td>unassignedbugs@nondot.org
</td>
</tr>
<tr>
<th>Reporter</th>
<td>llvm-dev@redking.me.uk
</td>
</tr>
<tr>
<th>CC</th>
<td>craig.topper@gmail.com, lebedev.ri@gmail.com, llvm-bugs@lists.llvm.org, spatel+llvm@rotateright.com
</td>
</tr></table>
<p>
<div>
<pre>We keep hitting issues with people not realising that these predicates can
contain some (but not all) elements that are undef. e.g. [<a class="bz_bug_link
bz_status_RESOLVED bz_closed"
title="RESOLVED FIXED - Bug in TargetLowering::SimplifyDemandedBits causing miscompile"
href="show_bug.cgi?id=43159">Bug #43159</a>]
These keep getting used in patterns like:
// fold (mul x, 0) -> 0
if (ISD::isBuildVectorAllZeros(N0.getNode())
return N0;
Should we rename these to isBuildVectorAllZerosOrUndefs or similar? Or is there
something else we can do to help avoid this?</pre>
</div>
</p>
<hr>
<span>You are receiving this mail because:</span>
<ul>
<li>You are on the CC list for the bug.</li>
</ul>
</body>
</html>