[Openmp-commits] [PATCH] D64217: [OpenMP][NFCI] Cleanup the target state queue implementation

Johannes Doerfert via Phabricator via Openmp-commits openmp-commits at lists.llvm.org
Thu Jul 4 12:45:09 PDT 2019


jdoerfert created this revision.
jdoerfert added a reviewer: openmp-commits.
Herald added subscribers: jfb, bollu.
Herald added a project: OpenMP.

Note: WIP patch 1/3 to go with a RFC for the device RTL design.

This NFCI patch includes the following cleanup steps:

- Merge the state-queue.h and state-queuei.h as the separation was artificial, and the files had a cyclic include dependence anyway.
- Remove the now obsolete state-queuei.h.
- Adjust the code according to the LLVM coding style, especially wrt. variable and method names.
- Change the names of types to be generic, or just less NVPTX specific.
- Wrap CUDA specific calls into __kmpc_impl_XXX functions and define them in an own target_impl.h file.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D64217

Files:
  openmp/libomptarget/deviceRTLs/nvptx/src/omp_data.cu
  openmp/libomptarget/deviceRTLs/nvptx/src/omptarget-nvptx.cu
  openmp/libomptarget/deviceRTLs/nvptx/src/state-queue.h
  openmp/libomptarget/deviceRTLs/nvptx/src/state-queuei.h
  openmp/libomptarget/deviceRTLs/nvptx/src/target_impl.h

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D64217.208070.patch
Type: text/x-patch
Size: 11288 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/openmp-commits/attachments/20190704/d5098ca1/attachment-0001.bin>


More information about the Openmp-commits mailing list