[llvm-dev] Bumping the CMake requirement for libc++ and libc++abi

Louis Dionne via llvm-dev llvm-dev at lists.llvm.org
Tue Mar 24 20:11:17 PDT 2020


The minimum CMake version currently advertised for libc++ and libc++abi is currently 3.4.3. I think the oldest version of CMake actually being tested on any builder is 3.7.0, so advertising 3.4.3 is somewhat of a lie (I'm pretty sure we're using features that require a more recent version already). However, we do need to bump it to 3.8.0 at least because CMake 3.7 doesn't know about C++17 in its compilation features, and we'll need that to build libc++ properly going forward. This will mean for bot owners:
1. They need to upgrade CMake on the builders to at least 3.8.0 (which is really easy), or
2. they can disable processing of libc++ and libc++abi's CMake files by making sure they do not appear in LLVM_ENABLE_PROJECTS

Any objections?


More information about the llvm-dev mailing list