[llvm-dev] changing variable naming rules in LLVM codebase

Kristof Beyls via llvm-dev llvm-dev at lists.llvm.org
Mon Feb 18 07:00:49 PST 2019

Op do 14 feb. 2019 om 14:02 schreef Nemanja Ivanovic via llvm-dev <
llvm-dev at lists.llvm.org>:

> I have to agree with Paul that I think it is rather useful to have a
> naming convention that distinguishes class members from locals, etc. I'm
> not sure what that would look like, whether an m prefix for data members
> would be something others would entertain, but something that makes it
> clear would probably be useful. To use Paul's example, I think that
> mTheStuff vs. TheStuff makes it super easy to visually identify what this
> is. I imagine this wasn't mentioned in this thread or previously adopted
> because of some good reason I am not aware of.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20190218/9f921159/attachment.html>

More information about the llvm-dev mailing list