[LLVMdev] Plea for help

Finn S Andersen finna at synputer.com
Tue May 4 09:45:03 PDT 2004

OK, details:

I run RH8 (gcc 3.2.something), RH9 (gcc 3.2.2-5) and Fedora.
Problems are the same across all setups. Hardware is Athlon 1600+
and half a giga RAM. Runs fail with an assertion when the linear
scan allocator is enabled, but runs without problems otherwise.

On RH9 (the system I have access to while generating this email) I
have the following details:

 > 1) The LLVM assembly language (.ll file) that is failing.
 - Attached.

 > 2) The version of GCC that you are using (gcc -v)
[finna at coplin11 ~]$ gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/specs
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man 
--infodir=/usr/share/info --enable-shared --enable-threads=posix 
--disable-checking --with-system-zlib --enable-__cxa_atexit 
Thread model: posix
gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)

 > 3) A brief description of your hardware, especially if it is 
something uncommon. 
 > I'm assuming your running on x86.  Running on another processor (like 
 > or even AMD's new 64 bit chips) might make a difference.
Its a plain athlon (actually there are two plain athlons, one running 
the other running 1.0GHz). Hardware has been used for more than a year
running heavyweight programs (chip design cad tools, for example).

 > 4) The exact command line that you use to configure LLVM, as well as the
 > name of the source and object directory names you use to store the 
 > and object files.
Under my home dir, /home/finna I have a 'llvm' dir containing
   * a 'build' dir, this is supposed to be the object dir in your 
   * a 'cfrontend' dir, generated by extracting the 1.2 release of the 
   * a 'llvm' dir, generated by getting latest cvs checkout
Standing in 'build' (/home/finna/llvm/build) I run
[finna at coplin11 build]$ ../llvm/configure 
(then gmake and gmake install).

Environment variables:

And aliases:
llvmg++ /home/finna/llvm/cfrontend/x86/llvm-gcc/bin/g++
llvmgcc /home/finna/llvm/cfrontend/x86/llvm-gcc/bin/gcc

 > 5) A copy of the Makefile.config file that is created in
 > the object root directory after running configure.
- attached.

Chris wrote in a followup:

> Can you send the output of 'llc -o - foo.bc -debug -print-machineinstrs'?

Attached as "linscan". (But added the "-regalloc=linearscan" to provoke 
the error).

For completenes, I also attach the a.out.bc bytecode, although I expect 
it can be generated
from a.out.ll.


That's it. I want to thank you very much for offering
this kind of support. I hope it won't be too embarrasing
for me when you find the error.

Best regards

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: a.out.ll
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20040504/a28d8470/attachment.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Makefile.config
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20040504/a28d8470/attachment-0001.ksh>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: linscan
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20040504/a28d8470/attachment-0002.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: a.out.bc
Type: application/octet-stream
Size: 1092 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-dev/attachments/20040504/a28d8470/attachment.obj>

More information about the llvm-dev mailing list