[PATCH] D157803: [JITLink][RISCV] Implement eh_frame handling

Jonas Hahnfeld via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 18 01:06:06 PDT 2023


Hahnfeld added inline comments.


================
Comment at: llvm/lib/ExecutionEngine/JITLink/ELF_riscv.cpp:462
       break;
+    case Delta32: {
+      int64_t Value = E.getTarget().getAddress() - FixupAddress + E.getAddend();
----------------
jobnoorman wrote:
> This is the same as `R_RISCV_32_PCREL` so maybe just reuse that one? At some point, `R_RISCV_32_PCREL` should be renamed to `Delta32` though.
Actually the (positive) `Delta` edges are not needed at all; the hypothetical `AddFDEToCIEEdges` discussed in https://reviews.llvm.org/D157802 only needs `NegDelta32`. That's another reason why I think it's the way to go.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D157803/new/

https://reviews.llvm.org/D157803



More information about the llvm-commits mailing list