[compiler-rt] fdb29f7 - [scudo] Rename AllocatorRingBuffer into scudo:ring_buffer
Fabio D'Urso via llvm-commits
llvm-commits at lists.llvm.org
Wed Sep 6 02:24:02 PDT 2023
Author: Fabio D'Urso
Date: 2023-09-06T11:23:27+02:00
New Revision: fdb29f7db56c6fec07fb077abad7cd89e641ef01
URL: https://github.com/llvm/llvm-project/commit/fdb29f7db56c6fec07fb077abad7cd89e641ef01
DIFF: https://github.com/llvm/llvm-project/commit/fdb29f7db56c6fec07fb077abad7cd89e641ef01.diff
LOG: [scudo] Rename AllocatorRingBuffer into scudo:ring_buffer
To maintain the convention of Scudo names starting with "scudo:",
which is used by some tooling to categorize memory usage.
Reviewed By: Chia-hungDuan
Differential Revision: https://reviews.llvm.org/D157102
Added:
Modified:
compiler-rt/lib/scudo/standalone/combined.h
Removed:
################################################################################
diff --git a/compiler-rt/lib/scudo/standalone/combined.h b/compiler-rt/lib/scudo/standalone/combined.h
index 12f229610921e9a..29589cdd99fa78a 100644
--- a/compiler-rt/lib/scudo/standalone/combined.h
+++ b/compiler-rt/lib/scudo/standalone/combined.h
@@ -1496,7 +1496,7 @@ class Allocator {
map(/*Addr=*/nullptr,
roundUp(ringBufferSizeInBytes(AllocationRingBufferSize),
getPageSizeCached()),
- "AllocatorRingBuffer"));
+ "scudo:ring_buffer"));
auto *RingBuffer = reinterpret_cast<AllocationRingBuffer *>(RawRingBuffer);
RingBuffer->Size = AllocationRingBufferSize;
static_assert(sizeof(AllocationRingBuffer) %
More information about the llvm-commits
mailing list