[PATCH] D157615: [ExtendLifetimes][1/4] Add "disable-post-ra" function attribute to disable the post-regalloc scheduler

Orlando Cazalet-Hyams via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Sep 1 08:50:11 PDT 2023


Orlando added inline comments.


================
Comment at: llvm/lib/CodeGen/PostRASchedulerList.cpp:282
 
+  if (Fn.getFunction().hasFnAttribute("disable-post-ra"))
+    return false;
----------------
StephenTozer wrote:
> Orlando wrote:
> > bikeshed: `disable-post-ra` seems potentially unclear. Perhaps `disable-post-ra-sched`?
> SGTM in principle, but it's worth noting that the flag to disable the post-RA scheduler is `-disable-post-ra`, so there's an argument that it would be more consistent to make the attribute and command line flag with identical functionality have the same name. I'm not attached to either side though, what do you think?
Ah, since there's precedent I think it's better to be consistent, so stick with it IMO (unless the name if changed to something more generic as per Jeremy's suggestion).


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D157615/new/

https://reviews.llvm.org/D157615



More information about the llvm-commits mailing list