[PATCH] D158791: [runtimes] Add a mechanism to use cache files for a runtimes build

Shoaib Meenai via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Aug 29 11:05:17 PDT 2023


smeenai added a comment.

In D158791#4623904 <https://reviews.llvm.org/D158791#4623904>, @phosek wrote:

> The fragments like https://github.com/llvm/llvm-project/blob/main/clang/cmake/caches/Fuchsia-stage2.cmake#L132-L184 and in particular https://github.com/llvm/llvm-project/blob/main/clang/cmake/caches/Fuchsia-stage2.cmake#L186-L289 have gotten quite unwieldy so I was already thinking about breaking those up into separate cache files and this feature is going to be needed so thank you!
>
> The open question is if we should try and encourage developers towards using separate caches to the point where we can eventually completely deprecate and remove the support for passthrough or we want to be maintaining both forever?

Hmm. I think separate cache files are going to be generally cleaner, but I can imagine cases where you only need to specify a couple of arguments and it's easier to inline them instead of creating a separate file. I think we can start with adding the support and converting our own runtimes build setups over and use that to get a sense of if there's still good use cases for separate passthroughs.

> Regarding the argument handling, I thought about alternatives but haven't come up with anything better. I have a question regarding the name though, we generally avoid the `CMAKE_` prefixed variables to potential (future) collisions (for example for CMake starts using `CMAKE_CACHES` in the future). Perhaps we should call this something like `LLVM_CACHE_FILES` or just `CACHE_FILES` for simplicty?

Good point, I'll change it.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D158791/new/

https://reviews.llvm.org/D158791



More information about the llvm-commits mailing list