[PATCH] D152081: [Attributor] Add lightweight version for attribute deduction only. (WIP)
Florian Hahn via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jul 6 13:33:46 PDT 2023
fhahn marked an inline comment as done.
fhahn added inline comments.
================
Comment at: llvm/include/llvm/Transforms/IPO/Attributor.h:3277
+struct LightweightAttributorPass
+ : public PassInfoMixin<LightweightAttributorPass> {
----------------
arsenm wrote:
> Document how the light one differs from the full
Added a short comment, thanks!
================
Comment at: llvm/lib/Passes/PassRegistry.def:45
MODULE_PASS("attributor", AttributorPass())
+MODULE_PASS("light-attributor", LightweightAttributorPass())
MODULE_PASS("annotation2metadata", Annotation2MetadataPass())
----------------
arsenm wrote:
> I think attributor-light would be better name so they sort together
Updated, thanks!
================
Comment at: llvm/lib/Transforms/IPO/Attributor.cpp:3681
+ {&AAWillReturn::ID, &AANoUnwind::ID, &AANoRecurse::ID, &AANoSync::ID,
+ &AANoFree::ID, &AANoReturn::ID, &AAMemoryLocation::ID,
+ &AAMemoryBehavior::ID, &AANoCapture::ID, &AAReturnedValues::ID,
----------------
arsenm wrote:
> Can you add AANoFPClass?
Done in latest version, thanks!
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D152081/new/
https://reviews.llvm.org/D152081
More information about the llvm-commits
mailing list