[PATCH] D154363: [WIP][mlir] Add an interface to decompose complex ops
Nicolas Vasilache via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Jul 4 03:37:15 PDT 2023
nicolasvasilache added inline comments.
================
Comment at: mlir/include/mlir/Dialect/Linalg/TransformOps/LinalgTransformOps.td:1162
+
+def DecomposeInterfaceOp : Op<Transform_Dialect, "structured.decompose_interface",
+ [FunctionalStyleTransformOpTrait,
----------------
I am sorry, I already polluted this name with the existing "decompose" op which actually does not in the same way.
We could rename the existing decompose as `downscale_to_1d` or something similar and you'd have the name for this more apt transformation you are adding.
This is fine for now, we can do the cleanup as a followup, but that should assuage your comment about `reuse the decompose one (albeit it won't work out of the box because that one only support linalg interfaces)` -> it is a different transform.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D154363/new/
https://reviews.llvm.org/D154363
More information about the llvm-commits
mailing list