[PATCH] D143762: [AMDGPU] Enable whole wave register copy
Yashwant Singh via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Jun 26 23:24:12 PDT 2023
yassingh updated this revision to Diff 534849.
yassingh added a comment.
- Rename PRED_COPY to WWM_COPY
- Review comments delete redundant isWWMCopy() check
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D143762/new/
https://reviews.llvm.org/D143762
Files:
llvm/include/llvm/CodeGen/TargetInstrInfo.h
llvm/lib/CodeGen/SplitKit.cpp
llvm/lib/CodeGen/SplitKit.h
llvm/lib/Target/AMDGPU/AMDGPU.h
llvm/lib/Target/AMDGPU/AMDGPUTargetMachine.cpp
llvm/lib/Target/AMDGPU/CMakeLists.txt
llvm/lib/Target/AMDGPU/SIInstrInfo.cpp
llvm/lib/Target/AMDGPU/SIInstrInfo.h
llvm/lib/Target/AMDGPU/SIInstructions.td
llvm/lib/Target/AMDGPU/SILowerWWMCopies.cpp
llvm/lib/Target/AMDGPU/SIMachineFunctionInfo.h
llvm/test/CodeGen/AMDGPU/llc-pipeline.ll
llvm/test/CodeGen/AMDGPU/sgpr-regalloc-flags.ll
llvm/test/CodeGen/AMDGPU/skip-subreg-copy-from-iswwmcopy-check.mir
-------------- next part --------------
A non-text attachment was scrubbed...
Name: D143762.534849.patch
Type: text/x-patch
Size: 23789 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20230627/23504923/attachment.bin>
More information about the llvm-commits
mailing list