[PATCH] D142218: [MC] Store implicit ops immediately after the TargetInsts table. NFC.

Jay Foad via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Feb 9 02:34:45 PST 2023


foad added inline comments.


================
Comment at: llvm/utils/TableGen/InstrInfoEmitter.cpp:910
+  OS << "struct " << TargetName << "InstrTable {\n";
+  OS << "  MCInstrDesc Insts[" << NumberedInstructions.size() << "];\n";
+  OS << "  static_assert(alignof(MCInstrDesc) >= alignof(MCPhysReg), "
----------------
barannikov88 wrote:
> Could `Descs` be a better name? So that you don't access it as `Insts.Insts` below.
> 
Maybe. It's actually e.g. `AMDGPUInsts.Insts`, but I guess your point still applies.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D142218/new/

https://reviews.llvm.org/D142218



More information about the llvm-commits mailing list