[PATCH] D142015: [LV] Plan with and without FoldTailByMasking
Sjoerd Meijer via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Thu Jan 19 09:24:23 PST 2023
SjoerdMeijer added a comment.
Thanks for working on this. General direction looks good to me, this is exactly what we want.
> VectorizationScheme was used to describe the pair of (FoldTailByMasking, VF). Alternative suggestions welcome
I was going to suggest PredicationScheme. But the VF is also part of it, so PredicationScheme does not covert it. Perhaps VectorizationScheme is just fine. :)
I have done only a first scan of the patch, but it is big, so need to do it again, which I will do soon.
================
Comment at: llvm/lib/Transforms/Vectorize/LoopVectorize.cpp:5764
unsigned
-LoopVectorizationCostModel::selectInterleaveCount(ElementCount VF,
+LoopVectorizationCostModel::selectInterleaveCount(VectorizationScheme VF,
InstructionCost LoopCost) {
----------------
Nit: perhaps rename this and in some other places to VS, so that the VF.Width references below become VS.Width.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D142015/new/
https://reviews.llvm.org/D142015
More information about the llvm-commits
mailing list