[PATCH] D140903: [DebugInfo][NFC] Rename is/setUndef to is/setKilllocation
Orlando Cazalet-Hyams via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 6 01:13:52 PST 2023
Orlando marked 2 inline comments as done.
Orlando added a comment.
Thanks for the review(s).
================
Comment at: llvm/lib/CodeGen/AssignmentTrackingAnalysis.cpp:2114
- // undef. Use i32.
- if (DVI->isUndef() || DVI->getValue() == nullptr || DVI->hasArgList())
return UndefValue::get(Type::getInt32Ty(DVI->getContext()));
----------------
StephenTozer wrote:
> I think the removal of `DVI->getValue() == nullptr` should be in the previous patch - would call it a nit, but probably important to preserve the obvious trivial-ness of this patch.
SGTM, that also lets me re-jig the patch dependencies a bit.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D140903/new/
https://reviews.llvm.org/D140903
More information about the llvm-commits
mailing list