[PATCH] D140903: [DebugInfo][NFC] Rename is/setUndef to is/setKilllocation
Stephen Tozer via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jan 4 08:30:48 PST 2023
StephenTozer accepted this revision.
StephenTozer added a comment.
This revision is now accepted and ready to land.
LGTM with the suggested "changes".
================
Comment at: llvm/lib/CodeGen/AssignmentTrackingAnalysis.cpp:2114
- // undef. Use i32.
- if (DVI->isUndef() || DVI->getValue() == nullptr || DVI->hasArgList())
return UndefValue::get(Type::getInt32Ty(DVI->getContext()));
----------------
I think the removal of `DVI->getValue() == nullptr` should be in the previous patch - would call it a nit, but probably important to preserve the obvious trivial-ness of this patch.
================
Comment at: llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp:6550-6552
- if (!LocOp)
- return false;
-
----------------
Also should be moved into the previous patch.
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D140903/new/
https://reviews.llvm.org/D140903
More information about the llvm-commits
mailing list