[PATCH] D139832: [IndVars] Support AND/OR in optimizeLoopExitWithUnknownExitCount

Max Kazantsev via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Dec 26 18:55:15 PST 2022


mkazantsev updated this revision to Diff 485332.
mkazantsev retitled this revision from "[IndVars] Support AND in optimizeLoopExitWithUnknownExitCount" to "[IndVars] Support AND/OR in optimizeLoopExitWithUnknownExitCount".
mkazantsev edited the summary of this revision.
mkazantsev added a comment.

Addressed Nikita's comments:

- OR is supported same as AND
- Logical AND and OR are also supported
- Got rid of code duplication, now the conditions are overwritten in existing instructions


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D139832/new/

https://reviews.llvm.org/D139832

Files:
  llvm/lib/Transforms/Scalar/IndVarSimplify.cpp
  llvm/test/Transforms/IndVarSimplify/eliminate-backedge.ll
  llvm/test/Transforms/IndVarSimplify/turn-to-invariant.ll

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D139832.485332.patch
Type: text/x-patch
Size: 20997 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20221227/2f95f4ab/attachment.bin>


More information about the llvm-commits mailing list