[PATCH] D133078: [X86][NFC] Refine load/store reg to StackSlot for extensibility

Xiang Zhang via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 5 19:29:29 PDT 2022


xiangzhangllvm added inline comments.


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3553
 
+static unsigned getLoadStoreOpcodeForFP16s(bool Load, const X86Subtarget &STI) {
+  if (STI.hasFP16())
----------------
LuoYuanke wrote:
> What does the suffix `s` mean? Rename it to `getFR16LoadStoreOpcode`?
Seems not need, Let me remove it.


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3864
+
+void X86InstrInfo::spillSpecialReg(MachineBasicBlock &MBB,
+                                   MachineBasicBlock::iterator MI, unsigned Opc,
----------------
LuoYuanke wrote:
> Rename it to `loadStoreTileReg`? It is unnecessary to introduce spill concept here.
OK, That is good.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D133078/new/

https://reviews.llvm.org/D133078



More information about the llvm-commits mailing list