[PATCH] D133078: [X86][NFC] Refine load/store reg to StackSlot for extensibility

LuoYuanke via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Sep 5 19:09:45 PDT 2022


LuoYuanke added inline comments.


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3553
 
+static unsigned getLoadStoreOpcodeForFP16s(bool Load, const X86Subtarget &STI) {
+  if (STI.hasFP16())
----------------
What does the suffix `s` mean? Rename it to `getFR16LoadStoreOpcode`?


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3864
+
+void X86InstrInfo::spillSpecialReg(MachineBasicBlock &MBB,
+                                   MachineBasicBlock::iterator MI, unsigned Opc,
----------------
Rename it to `loadStoreTileReg`? It is unnecessary to introduce spill concept here.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D133078/new/

https://reviews.llvm.org/D133078



More information about the llvm-commits mailing list