[PATCH] D133078: [X86][NFC] Refine load/store reg to StackSlot for extensibility
Xiang Zhang via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun Sep 4 23:55:58 PDT 2022
xiangzhangllvm added inline comments.
================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3852
+static bool SpecialOpcode(unsigned Opc) {
+ switch (Opc) {
----------------
xiangzhangllvm wrote:
> craig.topper wrote:
> > function names should be lower case and start with a verb. "SpecialOpcode" is also vague. Can it be more specific?
> let me rename it to isTILEReg, in fact, at first I consider it may has other specific reg (not only tile) in the futher, so I name it "Special".
> let me rename it to isTILEReg, in fact, at first I consider it may has other specific reg (not only tile) in the futher, so I name it "Special".
================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3852
+static bool SpecialOpcode(unsigned Opc) {
+ switch (Opc) {
----------------
xiangzhangllvm wrote:
> xiangzhangllvm wrote:
> > craig.topper wrote:
> > > function names should be lower case and start with a verb. "SpecialOpcode" is also vague. Can it be more specific?
> > let me rename it to isTILEReg, in fact, at first I consider it may has other specific reg (not only tile) in the futher, so I name it "Special".
> > let me rename it to isTILEReg, in fact, at first I consider it may has other specific reg (not only tile) in the futher, so I name it "Special".
>
>
> let me rename it to isTILEReg, in fact, at first I consider it may has other specific reg (not only tile) in the futher, so I name it "Special".
typo, sorry , isTILEReg --> isAMXOpcode
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D133078/new/
https://reviews.llvm.org/D133078
More information about the llvm-commits
mailing list