[PATCH] D133078: [X86][NFC] Refine load/store reg to StackSlot for extensibility

Craig Topper via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Sun Sep 4 20:35:33 PDT 2022


craig.topper added inline comments.


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3553
 
+static unsigned getLoadStoreOpcodeForFP16s(bool load, const X86Subtarget &STI) {
+  if (STI.hasFP16())
----------------
Capitalize `load` I know it was wrong before, but should we keep propagating it?


================
Comment at: llvm/lib/Target/X86/X86InstrInfo.cpp:3852
 
+static bool SpecialOpcode(unsigned Opc) {
+  switch (Opc) {
----------------
function names should be lower case and start with a verb. "SpecialOpcode" is also vague. Can it be more specific?


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D133078/new/

https://reviews.llvm.org/D133078



More information about the llvm-commits mailing list