[PATCH] D130479: [ORC_RT][COFF] Initial platform support for COFF/x86_64.

Lang Hames via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Aug 12 20:09:25 PDT 2022


lhames accepted this revision.
lhames added a comment.
This revision is now accepted and ready to land.

LGTM! Thanks @sunho! I'm very excited to see this land in-tree. :)



================
Comment at: llvm/tools/llvm-jitlink/llvm-jitlink.cpp:1222-1223
 
+Expected<JITDylib *> Session::getOrLoadDynamicLibrary(StringRef LibName,
+                                                      StringRef LibPath) {
+  auto It = DynLibJDs.find(LibName.str());
----------------
lhames wrote:
> sunho wrote:
> > lhames wrote:
> > > Is there any reason to make a distinction between `LibName` and `LibPath` here? Could we just use the path as the name?
> > It's separated because same DLL can exist in multiple include pathes. All the path stuffs is done to make sure we don't double import the same DLL.
> Are DLLs identified by filename alone then? Or is there some other way to tell whether two DLLs represent the same logical library?
Oh -- LibName here comes from `-


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130479/new/

https://reviews.llvm.org/D130479



More information about the llvm-commits mailing list