[PATCH] D130787: [lld][ELF] Rename SymbolTable::symbols() to SymbolTable::getSymbols(). NFC

Sam Clegg via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Aug 5 12:49:51 PDT 2022


sbc100 added a comment.

In D130787#3703040 <https://reviews.llvm.org/D130787#3703040>, @MaskRay wrote:

> I feel that `symbols()` is a better name. I am not sure the consistency with other ports matters in this case. The data structures are so different. Using `symbols` for symtab and `getSymbols` for `InputFile` has another benefit that we can easily distinguish the two use cases (which are very different).

But in the wasm port I have `.getSymbols()` for both the symbol table and for the `InputFile`.     So I guess I should change my symbol table to use `.symbols()`?     I do care about keeping the ports in sync as best I can, it helps with maintaining the wasm port to be able to compare them.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D130787/new/

https://reviews.llvm.org/D130787



More information about the llvm-commits mailing list