[PATCH] D123276: [lld-macho] Use fewer indirections in UnwindInfo implementation

Vy Nguyen via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri Apr 8 12:07:31 PDT 2022


oontvoo accepted this revision.
oontvoo added a comment.
This revision is now accepted and ready to land.

LG , except the duplicate structs but then I don't have a better suggestion /shrug



================
Comment at: lld/MachO/UnwindInfoSection.cpp:98
 
-template <class Ptr> struct CompactUnwindEntry {
+template <class Ptr> struct CompactUnwindLayout {
   Ptr functionAddress;
----------------
It seems a little iffy to me that we need this additional struct ... (Would be great to have only one of these two...)




================
Comment at: lld/MachO/UnwindInfoSection.cpp:107
+struct CompactUnwindEntry {
+  uint64_t functionAddress;
+  uint32_t functionLength;
----------------
int3 wrote:
> oontvoo wrote:
> > IIRC, this was changed to `Ptr` (it was originally `uint64_t`) because of an overflow bug on 32-bit platforms ... 
> > 
> maybe you were thinking of {D107035}?
Ah, yes. :)


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D123276/new/

https://reviews.llvm.org/D123276



More information about the llvm-commits mailing list