[PATCH] D123169: AtomicExpand: Change return type for shouldExpandAtomicStoreInIR
Phoebe Wang via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Tue Apr 5 21:10:24 PDT 2022
pengfei added inline comments.
================
Comment at: llvm/include/llvm/CodeGen/TargetLowering.h:2040-2041
+ /// Returns true if the given (atomic) store should be expanded by the
+ /// IR-level AtomicExpand pass into an "atomic xchg" which ignores its input.
+ virtual AtomicExpansionKind shouldExpandAtomicStoreInIR(StoreInst *SI) const {
----------------
Comments need update. Should we change the name to reflect the return type?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D123169/new/
https://reviews.llvm.org/D123169
More information about the llvm-commits
mailing list