[PATCH] D122428: Make BLAKE3 a component library

Nico Weber via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Mar 24 13:06:23 PDT 2022


thakis added inline comments.


================
Comment at: llvm/lib/Support/BLAKE3/CMakeLists.txt:49
+
+add_library(llvm_blake3 OBJECT EXCLUDE_FROM_ALL ${LLVM_BLAKE3_FILES})
+llvm_update_compile_flags(llvm_blake3)
----------------
MaskRay wrote:
> Should this be named `LLVMSupportBlake3` to match the prevailing library naming convention and BUILD.gn?
I can change it (done), but since it's an object library it doesn't really make it to disk (other than the name of the directory containing the .o files). So it doesn't matter too much either way I think.


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D122428/new/

https://reviews.llvm.org/D122428



More information about the llvm-commits mailing list