[PATCH] D119360: [flang] Upstream runtime changes for inquiry intrinsics
Pete Steinfeld via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Feb 9 12:41:15 PST 2022
PeteSteinfeld added inline comments.
================
Comment at: flang/include/flang/Runtime/inquiry.h:26
+ const char *sourceFile = nullptr, int line = 0);
+void RTNAME(Ubound)(Descriptor &result, const Descriptor &descriptor, int kind,
+ const char *sourceFile = nullptr, int line = 0);
----------------
klausler wrote:
> "array" would be a more descriptive name for the second argument than "descriptor".
Thanks. I'll change it.
================
Comment at: flang/runtime/inquiry.cpp:59
+ const Descriptor &array, const char *sourceFile, int line) {
+ SubscriptValue result{1};
+ for (int i = 0; i < array.rank(); ++i) {
----------------
klausler wrote:
> Since the function returns std::int64_t, that should also be the type of "result".
Good catch. I'll change it.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D119360/new/
https://reviews.llvm.org/D119360
More information about the llvm-commits
mailing list