[PATCH] D119360: [flang] Upstream runtime changes for inquiry intrinsics

Peter Klausler via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Wed Feb 9 11:56:33 PST 2022


klausler added inline comments.


================
Comment at: flang/include/flang/Runtime/inquiry.h:26
+    const char *sourceFile = nullptr, int line = 0);
+void RTNAME(Ubound)(Descriptor &result, const Descriptor &descriptor, int kind,
+    const char *sourceFile = nullptr, int line = 0);
----------------
"array" would be a more descriptive name for the second argument than "descriptor".


================
Comment at: flang/runtime/inquiry.cpp:59
+    const Descriptor &array, const char *sourceFile, int line) {
+  SubscriptValue result{1};
+  for (int i = 0; i < array.rank(); ++i) {
----------------
Since the function returns std::int64_t, that should also be the type of "result".


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D119360/new/

https://reviews.llvm.org/D119360



More information about the llvm-commits mailing list