[PATCH] D118797: [lld-macho][nfc] Eliminate InputSection::Shared

Jez Ng via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Feb 3 07:05:27 PST 2022


int3 added inline comments.


================
Comment at: lld/MachO/InputFiles.h:55
 // from the start of the original pre-split InputSection.
 struct Subsection {
   uint64_t offset = 0;
----------------
oontvoo wrote:
> int3 wrote:
> > oontvoo wrote:
> > > what would we call this `Subsection` if InputSection were to be renamed?
> > > 
> > > 
> > `SubsectionEntry` maybe. It is, after all, an entry into an ordered-map-like structure...
> Makes sense. I'd support renaming InputSection if you're up to doing it :)
> 
> (personally I don't feel strongly that lld-macho *has to* mirror file and type names 100% after elf, but that's just me)
mm I realize renaming InputSection also raises the question of what its subclasses should be named...

ConcatInputSection -> ConcatSubsection would be fine, I guess, but CStringInputSections are not subsections. But... we are placing them within `Sections::subsections` anyway, so maybe calling them subsections isn't totally wrong. Ugh naming is hard


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D118797/new/

https://reviews.llvm.org/D118797



More information about the llvm-commits mailing list