[PATCH] D117265: [MemoryBuiltins] [NFC] Rename isAllocationFn

Bryce Wilson via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Thu Jan 13 17:30:21 PST 2022


Bryce-MW created this revision.
Bryce-MW added a reviewer: reames.
Herald added subscribers: ormris, okura, jdoerfert, kuter, hiraditya.
Bryce-MW requested review of this revision.
Herald added a reviewer: jdoerfert.
Herald added a reviewer: sstefan1.
Herald added a reviewer: baziotis.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.

There have been a few times now where I have mixed up isAllocationFn with isAllocLikeFn. I've renamed it to isAllocOrReallocLikeFn. I'm open to something else, I juts think having both an isAllocationFn and isAllocLikeFn is confusing. It's als not clear what the difference is just looking at the name.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D117265

Files:
  llvm/include/llvm/Analysis/MemoryBuiltins.h
  llvm/lib/Analysis/GlobalsModRef.cpp
  llvm/lib/Analysis/MemoryBuiltins.cpp
  llvm/lib/Transforms/IPO/Attributor.cpp
  llvm/lib/Transforms/IPO/AttributorAttributes.cpp
  llvm/lib/Transforms/IPO/GlobalOpt.cpp
  llvm/lib/Transforms/InstCombine/InstCombineCalls.cpp
  llvm/lib/Transforms/InstCombine/InstructionCombining.cpp
  llvm/lib/Transforms/Scalar/DeadStoreElimination.cpp
  llvm/lib/Transforms/Scalar/GVN.cpp
  llvm/lib/Transforms/Scalar/NewGVN.cpp
  llvm/lib/Transforms/Utils/Local.cpp
  llvm/unittests/Analysis/MemoryBuiltinsTest.cpp

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D117265.399853.patch
Type: text/x-patch
Size: 10099 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20220114/85d6fe35/attachment-0001.bin>


More information about the llvm-commits mailing list