[PATCH] D116881: [ELF] Add Resolver class to relocation scan pass. NFC

Peter Smith via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jan 10 05:53:05 PST 2022


peter.smith added a comment.

In principle I'm in favour of having a class with a single public entry point. I agree with ikudrin's comments.



================
Comment at: lld/ELF/Relocations.cpp:408
+namespace {
+class Resolver {
+public:
----------------
I normally think of resolving a relocation when the final value is written. Given that the only public member function is called `scanRelocs`. Perhaps call the class `Scanner` or `RelocationScanner` the latter is more verbose but we could use `scan` instead of `scanRelocs`.

Regardless of what the name is, it will be good to have a comment to describe this large class. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D116881/new/

https://reviews.llvm.org/D116881



More information about the llvm-commits mailing list