[PATCH] D116800: [MemoryBuiltins] Remove isNoAliasFn() in favor of isNoAliasCall()
Johannes Doerfert via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 7 08:03:54 PST 2022
jdoerfert added a comment.
I like this, anyone else?
================
Comment at: llvm/lib/Transforms/IPO/AttributorAttributes.cpp:5272
- !isNoAliasFn(Obj, TLI))
- return false;
Constant *InitialVal = AA::getInitialValueForObj(*Obj, *L.getType(), TLI);
----------------
nikic wrote:
> This check is already performed within getInitialValueForObj(), I figured we may as well not duplicate the logic.
Agreed.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D116800/new/
https://reviews.llvm.org/D116800
More information about the llvm-commits
mailing list