[PATCH] D116800: [MemoryBuiltins] Remove isNoAliasFn() in favor of isNoAliasCall()
Nikita Popov via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Jan 7 01:19:26 PST 2022
nikic added inline comments.
================
Comment at: llvm/lib/Transforms/IPO/AttributorAttributes.cpp:5272
- !isNoAliasFn(Obj, TLI))
- return false;
Constant *InitialVal = AA::getInitialValueForObj(*Obj, *L.getType(), TLI);
----------------
This check is already performed within getInitialValueForObj(), I figured we may as well not duplicate the logic.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D116800/new/
https://reviews.llvm.org/D116800
More information about the llvm-commits
mailing list