[PATCH] D114101: [SLP]Improve analysis/emission of vector operands for alternate nodes.
Alexey Bataev via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Nov 24 10:49:32 PST 2021
ABataev added inline comments.
================
Comment at: llvm/lib/Transforms/Vectorize/SLPVectorizer.cpp:5049
+ // main/alternate ops.
+ auto &&ExistMatchingNode = [this, E]() {
+ for (const std::unique_ptr<TreeEntry> &TE : VectorizableTree) {
----------------
vporpo wrote:
> Nit: Perhaps rename `ExistsMatchingNode` to something a bit less ambiguous, for example like `FoundDiamondMatch` or `FoundMatchingShuffle` ?
Ok, will rename it.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D114101/new/
https://reviews.llvm.org/D114101
More information about the llvm-commits
mailing list