[PATCH] D113241: [lld-macho][nfc] rename parsed-section types & variables
Vy Nguyen via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Mon Nov 8 06:57:25 PST 2021
oontvoo added a comment.
also +1 to the s/section/subsection and SectionHeader renaming(much clearer now)
I've no strong opinion on Map vs Vec but generally I'm not a fan of putting the type (ie., vect, list, map, etc) into the variable name anyway. Seems redundant.
Perhaps if we could make the name clear enough, then it wouldn't be necessary to add the extra clarification.
================
Comment at: lld/MachO/InputSection.cpp:80
default:
- llvm_unreachable("Section type");
+ llvm_unreachable("ParsedSection type");
}
----------------
IMHO, it is not particularly clearer to say ParsedSection here
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D113241/new/
https://reviews.llvm.org/D113241
More information about the llvm-commits
mailing list