[PATCH] D111873: [NFC][LoopVectorize] Allow getRuntimeVF to generate FP values
David Sherwood via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Fri Oct 15 04:36:00 PDT 2021
david-arm added a comment.
In D111873#3066465 <https://reviews.llvm.org/D111873#3066465>, @lebedev.ri wrote:
> Passing-by remark: i don't see how this makes sense.
> VF is inherently an integral quantity, if something needs it as a float, should it not deal with the conversion?
It's because this will become a frequent pattern in future work, where we have to follow the same pattern of 1) convert float type -> int type, 2) invoke getRuntimeVF, 3) convert result back to FP. I wrote this patch on the basis that we'd prefer to reduce code duplication scattered throughout the vectoriser. It will make future patches in the area of tail-folding smaller.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D111873/new/
https://reviews.llvm.org/D111873
More information about the llvm-commits
mailing list