[PATCH] D111145: [AArch64][SVE] Propagate math flags from intrinsics to instructions

Peter Waller via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Oct 5 06:51:41 PDT 2021


peterwaller-arm added inline comments.


================
Comment at: llvm/lib/Target/AArch64/AArch64TargetTransformInfo.cpp:713
                                                          IntrinsicInst &II) {
+  auto *OpPredicate = II.getOperand(0);
   auto BinOpCode = intrinsicIDToBinOpCode(II.getIntrinsicID());
----------------
MattDevereau wrote:
> david-arm wrote:
> > nit: I'm not sure where the additional cosmetic code changes came from? It looks like you only really need to add the `setFastMathFlags` line?
> we had a short discussion about what looks better and might be easier to read, debug and work with. its a simple change if you disagree
For what it's worth I provoked this by suggesting in private that I wanted to see the parameter to IC.replaceInstUsesWith as its own variable in the original patch, and to generally avoid putting too much into a single line, for readability.

In the case of extracting OpPredicate I agree that it is marginal.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D111145/new/

https://reviews.llvm.org/D111145



More information about the llvm-commits mailing list