[PATCH] D106144: [AArch64][SVE] Move instcombine like transforms out of SVEIntrinsicOpts

Peter Waller via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Mon Jul 19 02:11:56 PDT 2021


peterwaller-arm accepted this revision.
peterwaller-arm added a comment.
This revision is now accepted and ready to land.

Naming nit, but otherwise LGTM.



================
Comment at: llvm/lib/Target/AArch64/AArch64TargetTransformInfo.cpp:829
+  case Intrinsic::aarch64_sve_tbl:
+    return instCombineTBL(IC, II);
   }
----------------
The majority of the other cases here have SVE in the name. Should we follow suit here? (No strong opinion either way, just pointing it out)

Also Ptest vs PTest -- the former doesn't appear in the codebase until this patch as far as I can see.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D106144/new/

https://reviews.llvm.org/D106144



More information about the llvm-commits mailing list