[PATCH] D105522: [llvm-readobj][XCOFF] Fix the error dumping for the first item of StringTable.
Qiu Chaofan via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jul 7 23:49:05 PDT 2021
qiucf added inline comments.
================
Comment at: llvm/tools/llvm-readobj/ObjDumper.h:113
- void printAsStringList(StringRef StringContent);
+ void printAsStringList(StringRef StringContent, uint8_t BeginByte = 0);
----------------
Esme wrote:
> shchenz wrote:
> > Maybe a more meaningful name would be `StringSizeFieldLength`?
> The function also called by ObjDumper::printSectionsAsString, which dumps the specified section(s), which doesn't have the field containing string content's length. So I think `StringSizeFieldLength` may be confused in that case?
What about `BeginOffset`? And why it's typed as `uint8_t`, `size_t` seems better as offset/length if there's not other reasons.
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D105522/new/
https://reviews.llvm.org/D105522
More information about the llvm-commits
mailing list