[PATCH] D105100: [NFC] Add new setDebugLocFromInst that uses the class Builder by default
Sander de Smalen via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Wed Jun 30 08:25:22 PDT 2021
sdesmalen added a comment.
Thanks for the changes. Can you update the title and commit message (which are now out of sync with the updated patch)?
I also left a nit, but otherwise the patch looks fine to me.
================
Comment at: llvm/lib/Transforms/Vectorize/LoopVectorize.cpp:552
+ /// \p V. If \p Ptr is None then it uses the class member's Builder.
+ void setDebugLocFromInst(const Value *V, Optional<IRBuilder<> *> Ptr = None);
----------------
nit: Can you rename `Ptr` to `CustomIRBuilder` or something?
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D105100/new/
https://reviews.llvm.org/D105100
More information about the llvm-commits
mailing list