[PATCH] D102509: [lld][X86] Restore gotEntrySize and gotPltEntrySize.

Harald van Dijk via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Fri May 14 09:45:40 PDT 2021


hvdijk created this revision.
hvdijk added reviewers: MaskRay, ruiu.
hvdijk added a project: lld.
Herald added subscribers: pengfei, arichardson, emaste.
hvdijk requested review of this revision.
Herald added a project: LLVM.
Herald added a subscriber: llvm-commits.

D62727 <https://reviews.llvm.org/D62727> removed GotEntrySize and GotPltEntrySize with a comment that they are always equal to wordsize(), but that is not entirely true: X32 has a word size of 4, but needs 8-byte GOT entries. This restores gotEntrySize and gotPltEntrySize (adjusted for current naming conventions), but defaults them to config->wordsize to keep things simple for architectures other than x86_64.

This partially reverts D62727 <https://reviews.llvm.org/D62727>.


Repository:
  rG LLVM Github Monorepo

https://reviews.llvm.org/D102509

Files:
  lld/ELF/Arch/X86_64.cpp
  lld/ELF/Symbols.cpp
  lld/ELF/SyntheticSections.cpp
  lld/ELF/Target.h
  lld/test/ELF/x86-x32-plt.s

-------------- next part --------------
A non-text attachment was scrubbed...
Name: D102509.345468.patch
Type: text/x-patch
Size: 7394 bytes
Desc: not available
URL: <http://lists.llvm.org/pipermail/llvm-commits/attachments/20210514/16cc1489/attachment.bin>


More information about the llvm-commits mailing list