[PATCH] D102137: [lld-macho] Don't reference entry symbol for non-executables
Jez Ng via Phabricator via llvm-commits
llvm-commits at lists.llvm.org
Sun May 9 17:11:24 PDT 2021
int3 marked 2 inline comments as done.
int3 added inline comments.
================
Comment at: lld/MachO/Config.h:76
struct Configuration {
- Symbol *entry;
+ Symbol *entry = nullptr;
bool hasReexports = false;
----------------
gkm wrote:
> Nit: The name `entry` is too generic.
the other LLD ports use just `entry` too
================
Comment at: lld/test/MachO/entry-symbol.s:10
# CHECK-LABEL: SYMBOL TABLE
-# CHECK-NEXT: {{0*}}[[#%x, ENTRY_ADDR:]] {{.*}} __TEXT,__text _not_main
+# CHECK: {{0*}}[[#%x, ENTRY_ADDR:]] {{.*}} __TEXT,__text _not_main
# CHECK: sectname __text
----------------
gkm wrote:
>
It's supposed to be aligned to the "SYMBOL TABLE" contents above. The sectname stuff below is from a different part of the objdump output. I'll add a newline to make things clearer
Repository:
rG LLVM Github Monorepo
CHANGES SINCE LAST ACTION
https://reviews.llvm.org/D102137/new/
https://reviews.llvm.org/D102137
More information about the llvm-commits
mailing list