[PATCH] D101393: [lld-macho][NFC] define more strings in section_names:: and segment_names::

Greg McGary via Phabricator via llvm-commits llvm-commits at lists.llvm.org
Tue Apr 27 14:11:06 PDT 2021


gkm marked an inline comment as done.
gkm added inline comments.


================
Comment at: lld/MachO/MergedOutputSection.cpp:58-60
+    error("Cannot add merge section; inconsistent type: old=" +
+          std::to_string(SECTION_TYPE & flags) +
+          ", new=" + std::to_string(sectionFlag));
----------------
int3 wrote:
> technically a change in an error message is a functional change :)
> 
> It seems like we are lacking a test for this; could you add it in this diff?
> 
> Also I think the flags would be more readable as hex values (there's `to_hexString()` in ScopedPrinter.h)
Oops. This change should migrate back into the builtin-section-renaming diff.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D101393/new/

https://reviews.llvm.org/D101393



More information about the llvm-commits mailing list